vSphere 6.5 – ESXi host unable to join HA or is evicted from HA cluster after a failure – Operation timed out

I recently ran into an issue where one of my ESXi hosts reported errors with HA. I attempted to Reconfigure HA on this host which resulted in the following: Operation timed out.

I then attempted to reconfigure HA entirely – all the other hosts joined except for this one, disconnecting and reconnecting the host, and removing the host from inventory did not alter the behavior. For the life of me I couldn’t get this host to join. So I opened a support call.

I had a Dell based ESXi image installed on this host initially and I had applied a VMware based security patch to this host. Apparently mixing and matching is a no no, this was a known issue in their internal KB which was not open to the public. The only resolution was to reinstall the host (which did resolve the issue).

Maybe it is best to strictly stick to the VMware based images since vendor based images  will usually be behind the curve when security flaws are known and a patch is needed to harden your ESXi host.

 

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s